Get window but nothing else when running tutorial

Return to Installation

Get window but nothing else when running tutorial

Postby linuxdesire » Sat Apr 16, 2016 10:49 am

I have Ubuntu 14.04 installed. I ran the following code that was in the manual.

Code: Select all
from direct.showbase.ShowBase import ShowBase
 
class MyApp(ShowBase):
 
    def __init__(self):
        ShowBase.__init__(self)
 
        # Load the environment model.
        self.scene = self.loader.loadModel("environment")
        # Reparent the model to render.
        self.scene.reparentTo(self.render)
        # Apply scale and position transforms on the model.
        self.scene.setScale(0.25, 0.25, 0.25)
        self.scene.setPos(-8, 42, 0)
 
app = MyApp()
app.run()


All I get is the window I do not get the green grass as pictured in the manual. I ran python Panda3dTest.py and it printed out:

Known pipe types:
glxGraphicsPipe
(All display modules loaded.)

I checked version of Python and I am running 2.7.6

Not sure what is going on. Please advise. Thank you.
linuxdesire
 
Posts: 2
Joined: Sat Apr 16, 2016 10:43 am

Re: Get window but nothing else when running tutorial

Postby rdb » Sat Apr 16, 2016 1:07 pm

What GPU and drivers do you have installed?
rdb
 
Posts: 11225
Joined: Mon Dec 04, 2006 5:58 am
Location: Netherlands

Re: Get window but nothing else when running tutorial

Postby linuxdesire » Sun Apr 17, 2016 9:50 am

I have integrated graphics. I ran lspci and this what I get.

00:02.0 VGA compatible controller: Intel corporation 2nd generation core processor or Family integrated graphics controller (rev 09)

My laptop has Intel Core I7-2627M CPU@2.70 GHz x 4 OS 64bit Memory 15.5Gb.
linuxdesire
 
Posts: 2
Joined: Sat Apr 16, 2016 10:43 am

Re: Get window but nothing else when running tutorial

Postby rdb » Tue Apr 19, 2016 9:16 am

Can you run other OpenGL programs fine, like "glxgears"?

Could you post the output of "glxinfo", and the output of "pview" after setting "notify-level-glgsg debug" in your /etc/Config.prc file?
rdb
 
Posts: 11225
Joined: Mon Dec 04, 2006 5:58 am
Location: Netherlands


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest