Missing Bullet Module

Return to Installation

Missing Bullet Module

Postby juaninskirt3d » Wed Mar 15, 2017 12:45 pm

Hi.
I have a problem.

I used to work with panda 3d a few years ago in windows, everything worked perfectly, but now i am in a Linux machine (OS: Tahr Puppy 6 , i can perfectly run Ubuntu software), everything works perfecly except that when i try to import Bullet
Code: Select all
 from panda3d.Bullet import BulletWorld
i get
Code: Select all
Missing module Bullet

I checked and i dont have installed
libpandabullet.so
nor any bullet related lib in panda's folder.

I would use ODE but i have a huge set of libraries for fast development and port it to ODE will be a lot of work.

Do you have any solution?

Thanks for your time
juaninskirt3d
 
Posts: 1
Joined: Wed Mar 15, 2017 12:29 pm

Re: Missing Bullet Module

Postby Moguri » Thu Mar 16, 2017 9:56 am

The module is is "bullet" not "Bullet," so you need

Code: Select all
from panda3d.bullet import BulletWorld


What version of Panda are you using? Did you build Panda yourself, or did you use a pre-compiled version? If pre-compiled, where did you get the build from?
Moguri
 
Posts: 58
Joined: Fri May 15, 2015 1:35 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest