Ubuntu Trusty fail on install of 1.9.3

Return to Installation

Ubuntu Trusty fail on install of 1.9.3

Postby rorschachrev » Thu Mar 23, 2017 11:26 pm

Hello, I'm using Linux Mint (a re-release of Ubuntu with less cloud integration, less stuff in general) and I'm having a dependency naming issue. The appropriate libraries are installed but not recognized by the panda3d 1.9.3 Ubuntu Trusty package. Based on the naming conventions, I doubt that I am the only user to be affected by this.

With these repos:
deb http://packages.linuxmint.com qiana main upstream import #id:linuxmint_main
deb http://extra.linuxmint.com qiana main #id:linuxmint_extra
deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner
deb http://ppa.launchpad.net/panda3d/ppa/ubuntu trusty main

I have this fail on dpkg -i panda3d1.9_1.9.3~trusty_i386.deb
dpkg: dependency problems prevent configuration of panda3d1.9:
panda3d1.9 depends on libavcodec54 (>= 6:9.1-1) | libavcodec-extra-54 (>= 6:9.20).
panda3d1.9 depends on libavformat54 (>= 6:9.1-1).
panda3d1.9 depends on python2.7.

Forced to do a apt-get -f install which removes panda3d from pending install list.
apt-cache show python2.7 | grep Version
Version: 2.7.6-8ubuntu0.3

apt-cache show libavcodec54 | grep Version
Version: 6:9.20-0ubuntu0.14.04.1
Version: 6:9.11-2ubuntu2 (note, one of these is from "security" but they have the same md5sum)

apt-cache show libavformat54 | grep Version
Version: 6:9.20-0ubuntu0.14.04.1
Version: 6:9.11-2ubuntu2

I'm not skilled enough with package editing to propose a solution. Any ideas?
rorschachrev
 
Posts: 4
Joined: Wed Jul 27, 2016 8:07 am

Re: Ubuntu Trusty fail on install of 1.9.3

Postby rdb » Fri Mar 24, 2017 4:43 am

dpkg does not do any dependency resolution. If you use a different package installer, such as gdebi, I suspect it will do the right thing. You could also try "aptitude -f install" since aptitude is smarter than apt-get in that it lets you choose between several resolution plans.
rdb
 
Posts: 11223
Joined: Mon Dec 04, 2006 5:58 am
Location: Netherlands

Re: Ubuntu Trusty fail on install of 1.9.3

Postby rorschachrev » Sat Mar 25, 2017 4:21 am

I had tried gdebi first by clicking the download. Thank you for the suggestions, I'll play with aptitude more in the future. The actual issue was my own silliness, I downloaded the 386 version on a 64 bit install. gdebi complained correctly about the architecture, but the command line tools I used above did not mention architecture, only version numbers. Thank you again!
rorschachrev
 
Posts: 4
Joined: Wed Jul 27, 2016 8:07 am


Return to Installation

Who is online

Users browsing this forum: Bing [Bot] and 3 guests