FrameBufferProperties available less than requested

Return to Scripting Issues

FrameBufferProperties available less than requested

Postby liuzhengcai » Thu May 03, 2012 8:19 pm

Hi,

We make a lab,use DLP link glasses (120 Hz DLP-projector) .

and set framebuffer-stereo 1 .

but with opengl mode, we got [FrameBufferProperties available less than requested ] worning,and no stereo effect .

graphics card is NV GT540M and ATI 5700
liuzhengcai
 
Posts: 26
Joined: Fri Oct 08, 2010 2:53 am
Location: Beijing,China

Postby rdb » Sun May 06, 2012 5:27 am

Does your OpenGL driver support stereo rendering?
rdb
 
Posts: 9692
Joined: Mon Dec 04, 2006 5:58 am
Location: Netherlands

Postby liuzhengcai » Mon May 07, 2012 3:36 am

we used ati5700,and latest driver

This time without warning message

but no stereo effect,no double image
liuzhengcai
 
Posts: 26
Joined: Fri Oct 08, 2010 2:53 am
Location: Beijing,China

Postby liuzhengcai » Mon May 07, 2012 3:37 am

in directx mode,it has double image,but no stereo effect
liuzhengcai
 
Posts: 26
Joined: Fri Oct 08, 2010 2:53 am
Location: Beijing,China

Postby drwr » Mon May 07, 2012 12:59 pm

You might have to enable stereo mode in the driver settings. I know this is a setting for NVidia cards, but I've never tried it with ATI.

David
drwr
 
Posts: 11425
Joined: Fri Feb 13, 2004 12:42 pm
Location: Glendale, CA

Postby liuzhengcai » Mon May 07, 2012 9:48 pm

we used NVidia cards(GTS 550Ti and GT540M),and latest driver, got [FrameBufferProperties available less than requested ] warning

what is the setting for NVidia cards?
liuzhengcai
 
Posts: 26
Joined: Fri Oct 08, 2010 2:53 am
Location: Beijing,China

Postby liuzhengcai » Mon May 07, 2012 9:51 pm

the DLP Projector is optoma ex762
liuzhengcai
 
Posts: 26
Joined: Fri Oct 08, 2010 2:53 am
Location: Beijing,China

Postby drwr » Tue May 08, 2012 2:53 pm

The NVidia Control Panel has a whole tab called "Manage 3D Settings". There are many settings under that tab that control precisely what happens when Panda (or any other 3-D application) requests a stereo buffer. The default is to do nothing.

David
drwr
 
Posts: 11425
Joined: Fri Feb 13, 2004 12:42 pm
Location: Glendale, CA

Postby liuzhengcai » Wed May 16, 2012 3:16 am

Now we use iz3d software,It works well,but only in directx mode.
liuzhengcai
 
Posts: 26
Joined: Fri Oct 08, 2010 2:53 am
Location: Beijing,China

Re: FrameBufferProperties available less than requested

Postby score1-4thehometeam » Wed Jun 04, 2014 8:29 pm

Did you ever get this working? Im attempting a similar thing and right now, and all i get is a jittering effect and my emitter wont sync.

Sidequestion: is pyopengl included in the panda3d install?
score1-4thehometeam
 
Posts: 27
Joined: Thu Mar 03, 2011 3:27 pm
Location: Tempe


Return to Scripting Issues

Who is online

Users browsing this forum: Bing [Bot], rdb and 0 guests