Setting up P3D in Eclipse?

Return to C++ coding using Panda3D

Setting up P3D in Eclipse?

Postby Rainfur » Thu Jun 07, 2012 12:24 pm

Right now, I'm trying to set up P3D in eclipse, to be coded in C++. I've mucked a bit around in it, but can't figure out anything. Is there a tutorial or something using it?

Also, I've tried using MSVS (microsoft visual C++ Express), but can't figure out how to delete the NVDEBUG macro, as Alt+F8 doesn't work, and it's not under the view menu. =/
Rainfur
 
Posts: 4
Joined: Thu Jun 07, 2012 12:22 pm

Postby tah » Thu Jun 07, 2012 1:30 pm

Hi

Don't know about eclipse, but as for NDEBUG, remove it from your preprocessor settings under the properties popup.

like this:

In the Solution Explorer window (usually on left side), right click on the bold text project name to get the menu and left click on "Properties". You'll see a popup and in its left side window expand the "C/C++" option, then in there select "Preprocessor", then you'll see the page for that display where at the top is an area where you would remove NDEBUG.
tah
 
Posts: 173
Joined: Fri Oct 29, 2010 3:25 pm
Location: Torrance, CA.

Postby Rainfur » Thu Jun 07, 2012 1:41 pm

Thank you!
Rainfur
 
Posts: 4
Joined: Thu Jun 07, 2012 12:22 pm

Postby dri » Fri Jun 08, 2012 7:57 pm

I'm using Eclipse but under Linux. Here's two shotscreens of my setup, if it can help:
http://imageshack.us/photo/my-images/26 ... setup.png/
http://imageshack.us/photo/my-images/83 ... setup.png/
dri
 
Posts: 48
Joined: Sat May 12, 2012 2:40 am


Return to C++ coding using Panda3D

Who is online

Users browsing this forum: No registered users and 1 guest